Godox Trigger Updated Firmware

mazza1967

I'm New Here
Dec 2, 2016
23
0
Godox just sent me v20 update for the x1c triggers my M5 now works with all my godox via the trigger :) not on the site yet but if anyone needs Pm and il will mail it to you :) I guess this will cover the Mkiv 5d and new models too
 

BasXcanon

EOS T7i
Oct 6, 2016
83
5
Thats great!

Will the XT-c now work with the powershot G-series aswell?
Since the M5 runs with powershot software if I have to believe the magic latern guys.
 

mazza1967

I'm New Here
Dec 2, 2016
23
0
It sure what models it updates as Godox were responding to me mail them week in week out to get an update for the M5 ( prob made no difference) they didn't tell me what cameras it updated but I guess anything launched late last year would be included at least up to the M5 launch anyway
 

mazza1967

I'm New Here
Dec 2, 2016
23
0
Okay so tested the V20 today and it will not work with the 6d removes camera control , Works with M5 fine , I have rolled back the driver to V19 and all okay so now running 2 triggers 1 with V19 for 6D and The other V20 for the M5
 

Besisika

How can you stand out, if you do like evrybdy else
Mar 25, 2014
638
26
Montreal
I have two of them, one V18 and the other V20 and both work perfectly on 1DX II and 5D III. I had trouble with V19 but after sometime playing with the options I upgraded it to V20, still didn't work, then all of a sudden started working. I don't even know what did I do. I guess something was not connecting properly inside. Both work well for at least a week now.
 

Besisika

How can you stand out, if you do like evrybdy else
Mar 25, 2014
638
26
Montreal
I just sent it to you. This is the same as mazza1967 sent to me. It is a Windows version.
 

BasXcanon

EOS T7i
Oct 6, 2016
83
5
Thank you Besisika!

So if the V20 does not work with my 80D I can easily reverse the version via the Godox G1 client?
 

mazza1967

I'm New Here
Dec 2, 2016
23
0
Hi Sorry only just got you message Ive been off shooting , I am getting on fine with triggers set up for each camera , I guess Godox are still refining it which is prob why its not on their own download page , and yes as long as you save a a version v18 or 19 you can just respect it and replace v20 thats what I did , I had assumed it would work with 6d but had issues with remote power control on groups , V20 seems to work fine with the M5 Just ensure you have a and earlier V to roll it back to
 

BasXcanon

EOS T7i
Oct 6, 2016
83
5
It is alright Mazza!

I need a 2nd X1-C anyway.
I will let the forum know if the version from Basisika works on the 80D when I receive my 2nd transmitter and install V20 on it.
 

mihazero

EOS M50
Jul 22, 2011
37
2
I have just tried new v20 (beta) firmware (thanks Besisika) and here is what i learned.

On 5D mark IV TTL still overexposes, but not as much as it used to. Before my flash was always reading F8.0, regardless what my actual f-stop was, hence trying to compensate. With new firmware it reads f-stop thats set on camera, but still overexposes, by at least 3 stops. Manual has worked fine before, so, nothing new there. AF Assist lamp didnt work for me before, still doesnt.

I hope final version of firmware will fix these issues.
 

BasXcanon

EOS T7i
Oct 6, 2016
83
5
Hi guys, there was a problem with the delivery of the 2nd XT1C that I ordered.
But it finally came it. It seems to work with the 80D. V20 shows in the menu that the TT350 zoom head should be able to control from the transmitter, but I don't got that working yet.

For all functions it seems to work.

BTW Mihazero, what lenses are you using on the 5dm4??
 

mihazero

EOS M50
Jul 22, 2011
37
2
BasXcanon said:
BTW Mihazero, what lenses are you using on the 5dm4??
Doesnt matter which one. Canon 35mm, 50 plastic fantastic, 100mm macro, 70-200. Always the same thing.
 

BasXcanon

EOS T7i
Oct 6, 2016
83
5
ok, well I had problem with one non cpu contact lens on my 80D in TTL model.
Are working in matrix measurement mode?
 

Besisika

How can you stand out, if you do like evrybdy else
Mar 25, 2014
638
26
Montreal
mihazero said:
I have just tried new v20 (beta) firmware (thanks Besisika) and here is what i learned.

On 5D mark IV TTL still overexposes, but not as much as it used to. Before my flash was always reading F8.0, regardless what my actual f-stop was, hence trying to compensate. With new firmware it reads f-stop thats set on camera, but still overexposes, by at least 3 stops. Manual has worked fine before, so, nothing new there. AF Assist lamp didnt work for me before, still doesnt.

I hope final version of firmware will fix these issues.
Funny thing but (just in case you make the same mistake I did) don't forget to turn the lamp assist on. It is the furthest button on the trigger.
I use FEC to compensate for the exposure. I use spot metering and that gets the exposure very close in TTL.
Notice that when shooting at night, the lowest you can go is 1/128th of power on the AD200, but if you use TTL you can go lower than that. It surprised me but even on speedlite I have the same thing. What I mean is that learn to use the TTL as in very low power requirement that is the only way to get the low power level needed. Someone may explain why. I can't. I just tried it.

The only issue I have with my 1DX II and the V20 is that the trigger turns on automatically the modelling light (I guess because it is not the official version yet), then I have to go to the flash to remove it.
 

SecureGSM

2 x 5D IV
Feb 26, 2017
1,228
257
MODELLING LIGHT ON / OFF –

A function to remotely turn the modelling light On and Off on strobes like the AD600B has also been added to the X1 transmitters.

Double pressing the Channel button will turn the modelling light ON or OFF.

C.Fn-05 – Enable 1/256 Power Level – [ 1/128 = OFF ] [ 1/128- = ON ] (1/256 is displayed as 1/12:cool:


more tips and tricks can be found here:

http://flashhavoc.com/godox-x1-c-ttl-triggers-for-canon-announced/

here is the good one, to trigger flash unit located very close to the trigger. I had an issue triggering flash unit in flash bracket located 8" directly above the trigger:

Q: Why X1 can not trigger in near distance
A:
Please upgrade the newly version(X1C V15,X1N V16,X1S V13), long press the TEST button and turn on the power simultaneously until STATUS blink for 2 seconds,0-30m remote control can be selected.

Q:X1 work normally, why the flash will be over-exposed sometimes?
A:
If work under TTL mode, please make sure you have proceeded the test flash and double check the output of the test flash

more here:L

http://www.godox.com/EN/Q&A.html




Besisika said:
...The only issue I have with my 1DX II and the V20 is that the trigger turns on automatically the modelling light (I guess because it is not the official version yet), then I have to go to the flash to remove it.
 

Besisika

How can you stand out, if you do like evrybdy else
Mar 25, 2014
638
26
Montreal
SecureGSM said:
MODELLING LIGHT ON / OFF –

A function to remotely turn the modelling light On and Off on strobes like the AD600B has also been added to the X1 transmitters.

Double pressing the Channel button will turn the modelling light ON or OFF.

C.Fn-05 – Enable 1/256 Power Level – [ 1/128 = OFF ] [ 1/128- = ON ] (1/256 is displayed as 1/12:cool:


more tips and tricks can be found here:

http://flashhavoc.com/godox-x1-c-ttl-triggers-for-canon-announced/
Oh good stuff! Thanks for letting me know.
I tried the CF05, it works on the AD600 but not the AD200 (as per Amazon Power Range: 8 F-Stops 1/1–1/128 Power)
I will try both when I get back home tonight.
So far, this trigger is very reliable
Thanks for the links as well.
 

Besisika

How can you stand out, if you do like evrybdy else
Mar 25, 2014
638
26
Montreal
Thanks SecureGSM for the tips.
Modeling light from the X1T works perfectly as well. Now I am fully set. I have 0 trouble with my both triggers; TTL, assist beam, modeling light, remote power control, and I have never had a misfire. The only time I had a misfire was when my AD200 overheated, but that was a user error. I forgot I had the AD200 in the softbox and I fired like it was the AD600.