New EOS M6 mark II completely bricked.

Nov 4, 2019
4
0
I purchased a EOS M6 Mark II on Sept 26th. We took the camera on a video shoot. We filmed HD video on Scandisc Ultra 64gb - Class 1. After about 5 minutes of filming the camera shut down and would not restart. We assumed it might have over heated so we left it for an hour - it still did not start .

We removed the card battery and lens, we inserted a new SD card and the camera started. We reset the camera to the factory setting hopeing this would clear any issues. We resumed filming - again the camera shut down - this time it gave an Error 70: Description: A malfunction with the images has been detected.
All images on the SD card were OK.

We have since replaced the camera.

I was wondering if the CANON EF-EOS-M Lens Mount Adapter which we purchased with the one of the first EOS M Cameras could cause the error? We are a bit reluctant to start swapping lens in case the new camera suffers the same fate

We used an official CANON EF-EOS-M Lens Mount Adapter with several different Canon lens. This adapter has also been used on a EOS M Camera. Lens used: Canon EF-S 17-55mm f28 IS USM LensCanon EF-M 18-55mm f35-56 IS STM. We also used a Tokina 11-16mm f28 AT-X Pro DX which was attached to the camera during one of the times the camera failed but not always.

We have also filmed with all the above equipment using an EOS M - we have never had any issues.

Anyone else had completed camera failure?


Thanks

Mike
 
Last edited:

Mt Spokane Photography

I post too Much on Here!!
Mar 25, 2011
15,925
1,040
Infant mortality. New products are more likely to fail than ones that have been used for a few months. It isn't common, but happens. Don't worry, keep on using it just as you have been.
 
  • Like
Reactions: dcm
Nov 4, 2019
4
0
Thanks for your response. Yep - an earlier model of the production line. Must admit the new camera sees more responsive. The annoyed thing we had to pay a 10% fee for not returning the broken camera complete/as sold. We had marked the battery and charger so we can disguise it almost the others. Seemed like we paid for the prvialge of having a broken camera.
 

LSXPhotog

EOS RP
Apr 2, 2015
398
239
www.diossiphotography.com
Wow, that's a pretty spooky thing to happen, and also voices the importance of having a backup camera. I haven't had any issues with mine and I took delivery around the same time as you - so it's an early run as well. Hope this one works out for you. I would love to know the cause of the failure.
 

Joules

EOS 6D MK II
Jul 16, 2017
830
880
Hamburg, Germany
I haven't had any issues with mine and I took delivery around the same time as you - so it's an early run as well.
The issue isn't as much about the early run. Every product you'll ever receive should get some testing shortly after you got it to ensure it works, regardless of how long it has been in production. Not every item goes through extensive testing on the manufacturers end, so there are always products with small defects getting shipped to customers. These small defects are mostly the ones that are easy to miss, or materialize only after some use.

After you have used your product for a hilw you can be fairly certain it does not have such a defect and the change for failure starts rising again only after you have used it a long time. It is what's meant when people mention the bathtub curve: The chance of product failure as a function of used time.

I think that's what Mt Spokane was referring to. So if you have used your camera already and found no problem, it is unlikely that it has one.
 

Keith_Reeder

I really don't mind offending trolls.
Feb 8, 2014
837
288
59
Blyth, NE England
Way back in 2007 I had two Canon 30D shutters fail on me - two different cameras - at < 5,000 actuations each, and within a week of each other.

Canon UK was great about it, and both were repaired in short order, but it emphasised to me very clearly that sometimes, things just break...
 
Nov 4, 2019
4
0
Hi Guys
Continued story of our EOS M6 Mk2. we have a replacement, which has worked fine since Oct. Until today, it has stopped communication with the lens, focusing and aperture. We have changed lenes, the battery, updated the Firmware, we have cleaned the contacts, reset the camera - still the same. We tired a EOS M lens - this stopped the camera turning on and produced Err60, other lens did not do this. Frustrating. Been told by our dealer to bring it into a a local shop.
 

Mt Spokane Photography

I post too Much on Here!!
Mar 25, 2011
15,925
1,040
Hi Guys
Continued story of our EOS M6 Mk2. we have a replacement, which has worked fine since Oct. Until today, it has stopped communication with the lens, focusing and aperture. We have changed lenes, the battery, updated the Firmware, we have cleaned the contacts, reset the camera - still the same. We tired a EOS M lens - this stopped the camera turning on and produced Err60, other lens did not do this. Frustrating. Been told by our dealer to bring it into a a local shop.
Thats certainly disgusting. I've had many many DSLR's, dozens. Only one failed when almost new. It was repaired and has worked fine since.
 

overniven

EOS M50
Apr 16, 2013
41
17
I've only had to deal with Canon Service once. They were pretty good. Much better than dealing with newer tech companies.

Hopefully, your issue gets taken care of quickly.
 

vxcalais

I'm New Here
Feb 11, 2020
10
2
Lucky here in Oz Canon introduced 5 year warranties on all their cams and lenses. Any dramas just drop it off to the store and they can deal with Canon.
 

Mt Spokane Photography

I post too Much on Here!!
Mar 25, 2011
15,925
1,040
I finally managed to get Canon to process a refund for a printer that arrived broken. I received a RMA and return label, and promptly sent it back. It was frustrating because they would not ship a replacement even if I paid. (the sale was over). When they received it a few days later, I called and they said it had not yet been processed by recieving but would send a refund. I ordered another that day because the sale was back on.
But, for 4 months now, I have not been able to get the refund. Finally, last week, a supervisor decided to issue it.

The whole experience was horrible. Fortunately, I had all the supporting paperwork, UPS tracking, RMA, dates, etc so there was plenty of proof.