5D mark III Locks up in Live View Mode Error 80



I just purchased a 5D mark III and the new Canon 24-70mm f2.8L II USM zoom lens. The first time I activated Live view mode and took a picture, the camera locked up with an error 80 message and a frozen image on the LCD that wouldn't even go away when I turned the camera off. Only solution was to remove the battery but the problem kept happening every time I took a picture with Live View activated. I tried reformatting the cards and shooting only with one card, but the problem persisted, so I took the camera back to Samy's Camera, where I purchased it. The manager swapped my lens with an identical zoom lens and after a few tries was able to reproduce the error. So without hesitation he gave me a new 5D body and we tested it with my lens. The exact same problem happened when I took the first picture in Live View mode. At this point the manager brought a third 5D body and I took about 20 pictures with my lens without problems, so I've taken this new body home with me, but something tells me there's some type of communication problem between this new lens and the 5D mark III. Has anybody experienced something similar?

Mt Spokane Photography

I post too Much on Here!!
CR Pro
Mar 25, 2011
Tens of thousands of users have not been reporting the issue, so it is a puzzle as to what is happening. Problems with equipment often are batch related, for example, a certain microchip or other hardware or firmware can be bad for a lot of product.
From your description, its not even clear if its a lens issue or a camera body issue. It could still be a lens issue, and just not showing up yet.
Let us know if it happens again.


Nov 13, 2012
Sounds like similar to 7D shutter issue, In live view mode 7D(ERROR 30) octagonally locks up the shutter
Not sure if this is similar to 5D error 80

Remove the memory card and take pictures in burst mode to release the shutter.


It´s a well known error in the first 5d Mark III´s.

Return the camera and demand a new one.

You pay a lot of money for the camera and you have the right to get a perfect one.
Mar 4, 2013
Had the same problem yesterday. Contacteer Canon Europe today and spoke to a technician. He explained me everyting. The following is the matter: error 80 (and 70 by the way) is given when there is a problem with the memorycard or the battery. The 5d III should be able to handel al kind of cards. The battery best can be a Canon.

if this problem occurs, there are two options: a softwareproblem (firmware) or a hardwareproblem.

In case of software: after resetting the camera, the problem should not come back (or maybe only ones or twice in the future). Resetting the camera: see below.

If the problem comes back offen after resetting, the only option is to sent the camera to the Canon repair centre. The hardware is the problem and needs replacement.

now how to reset the camera:

Lets try resetting your camera using the following steps to try and resolve this issue.

1. Turn the camera OFF and remove the memory card and battery first. Then detach the lens and place it out of the way. Use the camera body cap to prevent dust from getting inside and let the camera sit for 20 minutes.

2. In the interim please clean the lens contacts with a soft, lint free cloth. Use this to gently wipe the lens contacts. Sometimes the lens can lose contact with the camera if the contacts are dirty, so we want to be sure these are free from anything that could possible cause disruption.

3. Put these items back in the camera and turn the power switch to <OFF> and <ON> again.

4. Using the Mode Dial, change from Auto to Creative Zone modes and back testing each, to shoot and note if the issue persists.

5. Try a different Canon EF Series lens on the camera of any focal length.

hope this helps.



Jan 31, 2012
Ive seen occasional lock ups on my 5D MkIII twice in fact and both occasions I didnt need the images on the card so formatted the CF card, at that time I also have save JPG to seperate SD card which was not in the camera.

So just try to Format your card in camera when you've taken the images off it. ;)
It worked for me!
(I had no error just a complete lock up had to take the battery out.) not sure but I believe it was an after market battery I had in at the time but formatting worked.
<-- start Taboola -->