80D Buffer Playback Problem - Busy....Please wait

WilliamJ

I'm New Here
Aug 8, 2017
22
25
Hello folks.

I got an 80D recently to go alongside my 70D.

In most ways the 80D is a better camera, but my copy is unable to playback images as the buffer clears, which is something my 70D does no problem at all.

I've searched and searched and it's not a widely discussed issue, but anybody that has had the problem before usually hasn't been able to resolve it.

I've made a very quick video demonstrating my 70D playing back whilst the buffer clears no problem, and the same high speed card (Sandisk 64Gb Extreme Pro, freshly formatted in both) in the 80D was unable to playback until the full buffer was fully cleared, which is terribly slow and frustrating compared to the older 70D which can always keep up with my fast shooting style.

I've reset the 80D settings, turned off all the extra stuff like noise reduction etc etc, formatted, tried multiple high speed cards (Sandisk Extreme, Extreme Pro, 64Gb, 32Gb) - all of which work fine in the 70D. I only use official Canon batteries. I wonder if it's a bad copy or if the 80D uses a different processor that simply doesn't allow for both playback and writing to the card at once, perhaps due to the difference between 24MP and the 70D's 20MP.

Please see the video below.

Any advice greatly welcomed!

William
 

WilliamJ

I'm New Here
Aug 8, 2017
22
25
Not resolved sadly but Zig at Imaging resource did email me back with this helpful response. It seems to be an issue on some canons and not others, even 5D IV?!

‘Hi William -

Yes, we noticed the same behavior when we tested the 80D, as well as
on other models. Some cameras allow you to view just-shot images while
the buffer is clearing, but others do not. And in the case of Canon, it
doesn't even seem to depend on the version of DIGIC processor used.
For example, the EOS M50 and EOS R are both said to use DIGIC 8
processors, but the M50 doesn't allow you to view images while the
buffer is clearing, while the EOS R does.

We don't have details as to why they behave differently, but there could
be a hardware resource such as a bus or buffer memory that allows
shared access between the record and playback pipelines in some
models while in others shared access is not supported, perhaps to
reduce power consumption, PCB real-estate, etc. Who knows.

Regardless, what you are experiencing with your 80D is normal and
even occurs with some higher-end models such as the 5D Mark IV.

Hope this helps.

Zig
 

Jasonmc89

EOS 80D
Feb 7, 2019
309
345
UK
A bit annoying when I wanna quickly check framing or whatever but at least it’s normal. Cheers.