Problems after R5 Firmware update?

scottkinfw

Wildlife photography is my passion
CR Pro
I upgraded to the second firmware update and noticed that my R5 doesn't fire up! I have to press some buttons, move the lcd screen in and out, reverse it, and then, after some combination of moves, it does come to life. If I just wait and do nothing, the camera sits there without power.

Anybody else have this issue?

Thanks.

sek
 

Mt Spokane Photography

I post too Much on Here!!
CR Pro
Mar 25, 2011
16,528
1,478
I haven't bothered with it, nothing in it benefits me. A failed firmware installation usually means a trip to Canon. Do a total Camera reset if you can as a potential fix.
 

AlanF

Stay at home
CR Pro
Aug 16, 2012
7,506
7,537
I upgraded to the second firmware update and noticed that my R5 doesn't fire up! I have to press some buttons, move the lcd screen in and out, reverse it, and then, after some combination of moves, it does come to life. If I just wait and do nothing, the camera sits there without power.

Anybody else have this issue?

Thanks.

sek
Not me, a very smooth upgrade. Can you reinstall?
 

snappy604

EOS RP
CR Pro
Jan 25, 2017
479
318
mine has been fine other than it seemed to trigger the sensor cleaner more frequently... not entirely sure why it it does it. It does it when it's on not shut off and recovers very within half a second but it's disruptive. Its possible it's timing with power save mode going on (haven't had patience to test), but it should only trigger when powering off completely? .. .annoying but not enough to do anything about... yet.
 
  • Like
Reactions: digigal