R5 and new firmware: everything was perfect untill...

rico.29

I'm New Here
Feb 27, 2021
16
3
hello every body,
as you may know, i've had trouble with R5 and 500mm EF IS f4 V1, inacurate focus, lens continuesly focusing.
i knew it was no the lens, so i made a factory reset and all was perfect,
but i was waiting this new firmware because i think i will definitly fix possible AF problem.
so i installed it, P mode, no lens, battery ok.
and i test the R5 and 500mm with or without x1.4, also tested 100-500mm RF , and all was perfect , the 500mm f4 focused really fast , tracking was ok, no AF trouble at all.
so i went on the field did a few shots with x1.4, perfect), switch to 100-500mm, perfect, switch to 500mm+x1.4, perfect, 100-500mm, perfect, and back to 500mm+x1.4, and...
impossible to focus, i did not make a change on settings, AF keep tring to focus on subject , but still work perfect with 100-500mm.
i really don't understand.
i made a factory reset, nothing change,
any idea to fix this problem?

thanks .
 

Attachments

  • Capture d’écran (1).png
    Capture d’écran (1).png
    2.4 MB · Views: 90
  • Capture d’écran (2).png
    Capture d’écran (2).png
    2.1 MB · Views: 89
  • Capture d’écran (3).png
    Capture d’écran (3).png
    1.1 MB · Views: 82
  • Capture d’écran (4).png
    Capture d’écran (4).png
    1.6 MB · Views: 86

rico.29

I'm New Here
Feb 27, 2021
16
3
well, tried and tried the combo R5+500MM f4, V1, still the same , impossible to focus, AF gets close to subject but keeped chaning back and forward...
very frustrating.
what's even more frustrating, is that today, although i did nothing, did not change any setting, the combo works fine,
i really don't understand.
has any of you experiment such behaviour with any lens on any camera?
Thanks for your help.
 

HikeBike

R6 / R
CR Pro
Feb 6, 2019
145
152
Maryland, USA
The only time I have had an issue at all similar to this was when I was using my EOS R, and I had "Lens drive when AF impossible" set to OFF. In several cases, the camera would give up prematurely on achieving focus. So check that setting, and make sure it is set to ON. This very well might not be the cause of the issue you're experiencing, but it's worth checking.
 

Mt Spokane Photography

I post too Much on Here!!
CR Pro
Mar 25, 2011
16,697
1,663
In addition to the setting mentioned above, since the issue started after changing lenses, it could be a problem with the contacts. Look at the contacts on the back of the lens closely for any wear groves or bare metal. Then use a soft cloth barely damp with alcohol to wipe them. Its easy to try so nothing lost if it doesn't work. I don't think its the camera side since it works with other lenses.
 
  • Like
Reactions: HikeBike

rico.29

I'm New Here
Feb 27, 2021
16
3
thank you for your answers, i've checked and it's ok.
but sometimes the combo works great sometimes , not at all, impossible to focus.
the last time it did, was just after a short video, 1 or 2 s, i quickly switch to photo (before any AF on subject in video mode) to shot bird, but impossible to focus in photo mode.
so i quickly switch back to video mode (to check AF), focused on a subject, and went back to photo, and then, AF was ok.
is it possible that if i switch from video to photo, when i do not focus on anything in video, the AF is kind of "lost" in photo?