Yongnuo YN-E3-RT Incompatible with M5

DanP

EOS M6 Mark II
CR Pro
Dec 8, 2014
62
13
Does anyone know of a fix for the YN-E3-RT not working on the M5? It won't fire the compatible flash (it will by firing the test button, but not the shutter). I've searched the web and this was a known issue some time ago. I searched Yongnuo's USA website and it shows a firmware link for the YN-E3-RT, but clicking it gives a message that the file is no longer there. The transmitter will fire the flash on both the 5DIII & 5DIV. It's not a crisis for me as I also have the Canon version, which does work. However, I like having the cheap option when I'm concerned about possible loss or damage.
 

Valvebounce

EOS R5
CR Pro
Apr 3, 2013
4,455
349
53
Isle of Wight
Hi Dan.
I can’t tell you if these links still have the files attached, I’m on my iPad so can’t actually access these properly! :unsure:
I can tell you it says there is 153kb in the firmware file and 5.4mb in the trigger updater file when I click on them. (y)

Trigger Updater zip.
YN-E3-RT Firmware V1.26 zip.
These files along with firmware update instructions and downloadable instructions for the YN-E3-RT are Available Here.

I think I have downloaded these and used them on mine a while ago, I don’t remember seeing any difference to the operation on any of my SLR’s (7DII, 1DsIII, 40D) but that is not to say there weren’t differences under the hood!
Hope this helps.

Cheers, Graham.
 

DanP

EOS M6 Mark II
CR Pro
Dec 8, 2014
62
13
Hi Dan.
I can’t tell you if these links still have the files attached, I’m on my iPad so can’t actually access these properly! :unsure:
I can tell you it says there is 153kb in the firmware file and 5.4mb in the trigger updater file when I click on them. (y)

Trigger Updater zip.
YN-E3-RT Firmware V1.26 zip.
These files along with firmware update instructions and downloadable instructions for the YN-E3-RT are Available Here.

I think I have downloaded these and used them on mine a while ago, I don’t remember seeing any difference to the operation on any of my SLR’s (7DII, 1DsIII, 40D) but that is not to say there weren’t differences under the hood!
Hope this helps.

Cheers, Graham.
Thank you Graham. The firmware update appears to have solved the problem. The transmitter now fires the flash. I couldn't definitively tell from my test shot that the ETTL worked correctly, but the exposure looked reasonable. When I set +2 FEC in the camera menu, it certainly did overexpose. For anyone else intending to use the firmware update, the only problem I had was when browsing in the updater to the firmware file. When I double clicked on the file it gave me an error. When I right clicked the file and clicked "Open'' it worked fine.
 

Valvebounce

EOS R5
CR Pro
Apr 3, 2013
4,455
349
53
Isle of Wight
Hi Dan.
Happy to have helped you solve your problem, I just logged in on my PC to tell you I had found the files I downloaded and if you still couldn't get them online I was going to dropbox them for you.

Cheers, Graham.