Gear Talk > EOS Bodies - For Video

Iso dial freeze

(1/1)

thundermonkey:
Shooting a wedding last night and at one pointing attempted to vhange Iso with the top jog dial and it simply did nothing. Turned the camera off and on, same thing. Took batteries out and same. I tried changing menus and realized it was the dial itself more than anything. After a while it just worked. This freaked me out. Is it possible that I hit something to cause this? Should I be concerned?

Axilrod:
Were you shooting in manual mode?  If you were in Tv mode or something then it doesn't work while recording.  Either way I wouldn't worry about it too much if it's not doing it anymore.

MLD:
I used to have this happen on my 40D once in a while. At least for me, the fix was to turn the dial on my extended grip, which instantly made the normal dial start working again.

paul13walnut5:
Happened once on my 7d with grip.
I was in av mode and front dial wouldn't work (was in av modeand wanted to change aperture)

Panic, batts out back in, no change

More panic, grip off, checked body only = fine

Wiped strand of hair from grip contacts, back on = all good again.

thundermonkey:
I shoot exclusively in manual, yes. I have a pixel king grip on it as well. At least I know for now no need to think about having to return anything.

Navigation

[0] Message Index

Go to full version