April 20, 2014, 05:38:30 AM

Author Topic: 5D MKIII stutter speed fault  (Read 1322 times)

Cherish Photography

  • Guest
5D MKIII stutter speed fault
« on: February 02, 2013, 06:35:38 AM »
My camera has just developed a fault.  From time-to-time it won't allow me to change the shutter speed with the main dial.  I have to disconnect the battery and turn back on to fix the fault.  This is while in manual mode.

Very strange.  Anyone else had this fault?

canon rumors FORUM

5D MKIII stutter speed fault
« on: February 02, 2013, 06:35:38 AM »

J.R.

  • 1D X
  • *******
  • Posts: 1430
  • A Speedlight Junkie!
    • View Profile
Re: 5D MKIII stutter speed fault
« Reply #1 on: February 02, 2013, 07:37:51 AM »
Never ... unless I've accidentally activated the multi-function lock!
Light is language!

Cherish Photography

  • Guest
Re: 5D MKIII stutter speed fault
« Reply #2 on: February 02, 2013, 05:25:24 PM »
Thanks.  The multi-function lock hasn't been locked.  Just checked and I don't have the latest firmware, so I'll update that and hopefully the problem doesn't happen again.

Menace

  • 1D Mark IV
  • ******
  • Posts: 924
  • New Zealand
    • View Profile
Re: 5D MKIII stutter speed fault
« Reply #3 on: February 08, 2013, 05:55:23 AM »
Never had a prob like that. If the firmware doesn't fix it then I'm afraid the camera may need to go back to Canon.
5D III | 6D
50 1.2L | 85 1.2L II | 100 2.8 | 400 2.8L IS II 
24-70 2.8L II | 70-200 2.8L IS II

canon rumors FORUM

Re: 5D MKIII stutter speed fault
« Reply #3 on: February 08, 2013, 05:55:23 AM »