Wifi on 5dmkIV totally unstable - assistance needed

maboleth

I'm New Here
Aug 18, 2015
13
2
I've been trying to connect my camera wirelessly with my Ubee cable router for days, without success.

In a nutshell, the connection, when does happen, lasts 1-2min. Only a single time I have managed to connect the camera for good, without any disconnecting.

I tried:
1. Connecting on my wireless network manually with password
2. Using WPS button on the modem itself.

It takes several program and camera restarts to even see them connecting. Usually nothing happens.
At this point I don't know where to look anymore? Is it my modem, camera or Windows settings or all combined?

My machine is Windows 10 PC, latest drivers, AMD motherboard, chipset, cpu, gpu. Latest Canon Utility v3, latest camera firmware.
 

jprusa

EOS RP
CR Pro
Apr 29, 2013
445
134
Are you getting to the point where you enter your encryption key in network settings from camera? Have you ever connected to a device before?
 

maboleth

I'm New Here
Aug 18, 2015
13
2
Are you getting to the point where you enter your encryption key in network settings from camera? Have you ever connected to a device before?

Yes, I can see that camera connects to the modem itself (have it under "connected clients on my router menu") but either

a) Canon utility doesn't come up or recognize the camera actually connected.
b) The connection is there, I can access and do everything as normal, but disconnection happens after 1-3min. This is much more common than a).

Basically I'm trying to figure out why my connection isn't stable once established?
 

jprusa

EOS RP
CR Pro
Apr 29, 2013
445
134
For some reason I have to open my Canon Utility , then click on paring over WiFi and it connects. I had it connected to my iPad and later tried to connect to Mac and never could get to the point to enter key and found out iPad was in setup and I missed that info. It is disconnecting back to your WiFi if you don't connect with camera. Your camera will tell you if you connect.
 
Last edited:
<-- start Taboola -->