EOS R5 viewfinder and LCD screen flash white when doing a half shutter press. Has anyone else experienced this?

Juangrande

EOS RP
Mar 6, 2017
210
263
I have a recurring issue with my R5 where both the viewfinder and LCD will flash bright for a split second and whiteout the screen when doing a half shutter press to meter or attain focus. The resulting image is perfectly fine but it’s annoying and interferes with timing of image capture because of the distraction. My friend was also shooting images with the exact same camera body and lens RF 50mm 1.2 and did not have the issue. I also tried my RF 85 and canon EF 35 and Sigma 135 Art lens and had the same issue so it’s not the lenses causing the problem. I couldn’t figure out any settings that would cause this, does anyone know if there’s a setting conflict? Thanks got any help. Btw this doesn’t appear to happen outdoors in bright daylight only indoors or in deep shade.
 

JPAZ

If only I knew what I was doing.....
CR Pro
Sep 8, 2012
1,154
576
Maybe something to do with exposure simulation settings? Just a guess.
 

Juangrande

EOS RP
Mar 6, 2017
210
263
Maybe something to do with exposure simulation settings? Just a guess.
No, I though the same but I tried all the options of exposure simulation and the problem persists. I brought it in for service to the Canon repair facility in Costa Mesa after and demonstrated the issue in person and I got the camera mailed back to me today and the said said there’s no issue and gave me instructions in how to set exposure simulation, which was not the issue as I mentioned. Again my friends camera does not have this issue when we tested both together
 

JPAZ

If only I knew what I was doing.....
CR Pro
Sep 8, 2012
1,154
576
Just found a post on DPReview (about 10 months ago) where two people said this happens to them. No explanation given.

Another DPReview thread from August 2020 says the viewfinder "blinks" white when camera can't attain focus. I can't give any specific suggestion but think there is some setting that you can change on your on your R5 that makes his occur. Sorry I can't be of more help. Maybe have your camera and your friend's camera side by side and go through each menu to see what is different.

Good hunting.
 
Last edited:

wyotex43n

EOS M6 Mark II
Jan 24, 2016
76
59
I have a recurring issue with my R5 where both the viewfinder and LCD will flash bright for a split second and whiteout the screen when doing a half shutter press to meter or attain focus. The resulting image is perfectly fine but it’s annoying and interferes with timing of image capture because of the distraction. My friend was also shooting images with the exact same camera body and lens RF 50mm 1.2 and did not have the issue. I also tried my RF 85 and canon EF 35 and Sigma 135 Art lens and had the same issue so it’s not the lenses causing the problem. I couldn’t figure out any settings that would cause this, does anyone know if there’s a setting conflict? Thanks got any help. Btw this doesn’t appear to happen outdoors in bright daylight only indoors or in deep shade.
I have had a similar issue. When I turn the camera on by viewfinder goes almost to whiteout. Its very random. I have not noticed this happening with the half shutter press but I will keep an eye on it now that I am aware.
 
  • Like
Reactions: 1 user

SnowMiku

EOS 90D
Oct 4, 2020
133
93
Have you tried updating the firmware to 1.5.0 to see if it fixes the issue? I'm not sure if it would fix the issue but worth a try. Also it wouldn't hurt to try to see if you get this issue with no memory cards inserted.