Firmware: Canon updates firmware on various camcorders, adds C-Log 3

Canon Rumors Guy

EOS-1D X Mark III
CR Pro
Jul 20, 2010
8,916
1,670
Canada
www.canonrumors.com
Canon has released new firmware for various camcorders in their lineup including the XA40, XA55/XA50 and the XF405/XF400.
Canon XA40 v1.0.1.0

Adds support for the XF-AVC recording modes.
[4K UHD] 3840×2160 29.97P/23.98P/25P
[FHD] 1920×1080 59.94i/59.94p/50i/50p/29.97p/25p/23.98p
Adds [Custom Picture] modes that enables detailed image settings.
Expand assignable features to assign buttons.

Download firmware v1.0.1.0

Canon XF405/XF400 v1.0.5.0

Adds [Custom Picture] modes that enables detailed image settings.
Adds [EOS Standard] and [Production Camera] color matrix to [Custom Picture] parameter.
Expand assignable features to assign buttons.
Improves autofocus accuracy when zooming.
Improves image quality when using the [Digital Zoom] [Advanced 30X] mode.

Download firmware v1.0.5.0 for...


Continue reading...
 
Last edited:

Refraction

I'm New Here
CR Pro
Sep 5, 2020
23
23
I downloaded and installed this firmware for the XA40...no sign of a Clog3 option as mentioned in the headline to this article.
 

skp

5DIV, 7DII, 60D
CR Pro
Sep 20, 2014
50
47
That's pretty huge. I was thinking about an XF405 last year for event work, but decided against it because the lack of c-log was a deal breaker for high contrast outdoor events where I can't control any lighting. Thanks to 2020 being 2020, I haven't had a need at all for this style of camera. but if things change I might pick up a used xf405 in 2021.
 
Dec 22, 2020
2
0
Any other XF400/405 owners have any luck getting 100% zebras to work with CLog3? 70% works fine but is useless for monitoring for overexposure.
 
Dec 22, 2020
2
0
Any other XF400/405 owners have any luck getting 100% zebras to work with CLog3? 70% works fine but is useless for monitoring for overexposure.

Just as an FYI, in case anyone else has this problem, I discovered that you have to turn the View Assist feature on, when in CLog3, for the 100% zebras to work properly.
 
I have an XA50 and I upgraded the firmware to access the Custom Picture profiles in XF-AVC recording and use the Canon Log 3 profile. I just recorded a 2 minute sample and I wanted to ask if anyone can recommend what basic LUT I should use to convert this to REC.709. I found the LUT pack from Canon's website for the C300 mk II and I think there's a few options in there, but I'd love some advice from someone with a bit more experience than me :)
 
I downloaded and installed this firmware for the XA40...no sign of a Clog3 option as mentioned in the headline to this article.
On my XA50 I had to change a few settings to access it. I had to switch from MP4 recording to XF-AVC. Then inside the menu under "Camera Setup" on the last page was an option for "CP Function" which I had to turn "On". Then going back under the Function menu, where there was normally the "Custom Looks", there is now a "CP" section with 6 different color profiles, standard, Wide DR, C-Log 3, Monochrome, and two user assignable profiles. I hope that might help.
 

Refraction

I'm New Here
CR Pro
Sep 5, 2020
23
23
On my XA50 I had to change a few settings to access it. I had to switch from MP4 recording to XF-AVC. Then inside the menu under "Camera Setup" on the last page was an option for "CP Function" which I had to turn "On". Then going back under the Function menu, where there was normally the "Custom Looks", there is now a "CP" section with 6 different color profiles, standard, Wide DR, C-Log 3, Monochrome, and two user assignable profiles. I hope that might help.
Thanks, I actually found and switched to XF-AVC a couple of weeks ago for the higher bit rate. I must seek out the wide DR next.
 

Refraction

I'm New Here
CR Pro
Sep 5, 2020
23
23
On the XA40 there is the normal CP and 5 others that are not presets but can be assigned by the user. There is no Wide DR, C Log 3 or Monochrome built in.
 
<-- start Taboola -->