R5 wifi and iPhone

Viggo

EOS R5
Dec 13, 2010
4,638
1,329
Hi!

Does anyone actually get the R5 connected to and having the WiFi work ?

Think I’ve counted 12-14 different error messages on my R5 and iPhone now and I’m seriously about to throw them both out where I can’t see them ever again.

third time now I’ve spent a full battery to flat trying to get it to work like it did so easily on my old R.

before The 1.2.0 update I had managed to create a manual network thatmy iPhone and R5 both recognized and while it took forever to connect t compared to the R, it worked.

now it’s impossible to have it function. I followed the step by step in the user guide and it worked. Turn the camera and phone off anD try to connect again, nothing works. The name of the camera network changes each time so it won’t connect.
I’ve deleted all com.settings many times, deleted connections and Bluetooth and WiFi many times and started over. Nothing makes it connect through the app or at all. I’ve manually selected the WiFi network from the phone menu , doesn’t work.
How can I have it connect to the same network each time? If I can create a network and use the same every time it might work.

I’m seriously loosing my mind over how much they screwed this up compared to how it worked with the R. I didn’t even have the Bluetooth enabled with the R and it was great.

any tips would be greatly appreciated.
 

jprusa

EOS RP
CR Pro
Apr 29, 2013
421
113
I was able to connect on my iPad with no problems , easier than the mark 4 for sure. running the new update on R5. I connected via WiFi.I just put password in and joined network and opened software and R5 was recognized.
 
Last edited:

Mt Spokane Photography

I post too Much on Here!!
CR Pro
Mar 25, 2011
16,454
1,432
Its very easy on my Samsung, a Bluetooth connection can setup the Wi-Fi connection automatically. I don't have a iPhone any more but it worked fine with my SL2 when I had it. I also use wi-Fi to transfer to my PC. I'd never used FTP before but it turned out to be easy once I enabled FTP on my PC.

Canon is way ahead of others in wireless use but, it can be a challenge if its not done precisely right. That's where the Bluetooth method really shines. Once its paired, I just start canon connect on my phone, turn on the R5 and its there ready to operate remotely!

Were you using the Bluetooth Connection method or trying to connect Wi-Fi manually?
 

Viggo

EOS R5
Dec 13, 2010
4,638
1,329
I was able to connect on my iPad with no problems , easier than the mark 4 for sure. running the new update on R5. I connected via WiFi.I just put password in and joined network and opened software and R5 was recognized.
But when you do it the next time, do you enable Bluetooth on your iPad and open the app and it can connect to the WiFi? Or do you start WiFi on the camera and find that network on your iPad settings and then open the app and wait?

and does it use a different named WiFi every time?
 

Viggo

EOS R5
Dec 13, 2010
4,638
1,329
Its very easy on my Samsung, a Bluetooth connection can setup the Wi-Fi connection automatically. I don't have a iPhone any more but it worked fine with my SL2 when I had it. I also use wi-Fi to transfer to my PC. I'd never used FTP before but it turned out to be easy once I enabled FTP on my PC.

Canon is way ahead of others in wireless use but, it can be a challenge if its not done precisely right. That's where the Bluetooth method really shines. Once its paired, I just start canon connect on my phone, turn on the R5 and its there ready to operate remotely!

Were you using the Bluetooth Connection method or trying to connect Wi-Fi manually?
I have to use Bluetooth unlike with the R, otherwise it has failed 100% of the time.

I was also under the impression that if it’s connected via Bluetooth I should be able to open the Camera Connect app and have it connect to WiFi on its own. That doesn’t work withmine at all, I have to go to the settings menu on my phone and wait quite a while before the network even shows up and select it manually.
 

Mt Spokane Photography

I post too Much on Here!!
CR Pro
Mar 25, 2011
16,454
1,432
I have to use Bluetooth unlike with the R, otherwise it has failed 100% of the time.

I was also under the impression that if it’s connected via Bluetooth I should be able to open the Camera Connect app and have it connect to WiFi on its own. That doesn’t work withmine at all, I have to go to the settings menu on my phone and wait quite a while before the network even shows up and select it manually.
Something seems wrong. I thought turning Wi-Fi off on the camera might cause a problem so just now, I turned off Wi-Fi on my camera, restarted it, turned camera Wi-Fi on again and went to Canon connect and opened it. It connected in about 1-2 seconds.

I'm using a Galaxy S10+ after I could not find a new iPhone that would bring in a signal out where I live. They changed their radio to Intel which is less sensitive. Now, 1/2 the radio on the iPhone 12 is Qualcomm and might be more sensitive (Apple makes the antenna) but I have the new phone already. I also wear a Bluetooth hearing implant and the Galaxy is far better for that. The iPhone 11 would not work for 2 months with the implants until they fixed the firmware. Apple seems to do less testing of ios for infrequently used apps.
 
  • Like
Reactions: Viggo

jprusa

EOS RP
CR Pro
Apr 29, 2013
421
113
Just the Wifi connection and iPad came up , joined R5 network,, PW was already there . opened software and was connected.
 
  • Like
Reactions: Viggo

jprusa

EOS RP
CR Pro
Apr 29, 2013
421
113
Once you stop Wifi your connection you will have to rejoin the R5 network on your I phone because your device will default back to network.
 

Viggo

EOS R5
Dec 13, 2010
4,638
1,329
I tried again just turning Flight Mode off and opened the app and it actually worked two times, prompting me with “connect to network” but now, impossible again. I can’t for the life of me understand this crap.

why does it keep changing the name of the network. I used to just call them R5 and that was the one I could search for, but I can’t and it keeps changing and I have to do the whole
Process each and every time. But then it suddenly worked two times , but now nothing again...
 

koenkooi

EOS R
CR Pro
Feb 25, 2015
1,449
1,247
[..]Does anyone actually get the R5 connected to and having the WiFi work?[..]
I configured the R5 to connect to my home network to have better range. I select my phone connection from the R5 menu, it connects to my wifi and I open the Connect app on my phone. After a few seconds it will detect the R5 and I'm good to go.

When I'm away from home, I use the connect app to initiate the wifi, that will have it used one of those autogenerated names, pop up a dialog asking to connect and it's good to go afterwards.

I think the trick is to have bluetooth enabled on the camera all the time, things are fairly automated after that.
 

Viggo

EOS R5
Dec 13, 2010
4,638
1,329
I configured the R5 to connect to my home network to have better range. I select my phone connection from the R5 menu, it connects to my wifi and I open the Connect app on my phone. After a few seconds it will detect the R5 and I'm good to go.

When I'm away from home, I use the connect app to initiate the wifi, that will have it used one of those autogenerated names, pop up a dialog asking to connect and it's good to go afterwards.

I think the trick is to have bluetooth enabled on the camera all the time, things are fairly automated after that.
I tried that now, it connects one time, then turn camera off, end the connection and close the app on my phone. Start the app and press a button, it prompts if I wish to connect to the camera WiFi, the three dots starts to progress and then “failed to connect, grant permission to use local network” which is already enabled.
 

jprusa

EOS RP
CR Pro
Apr 29, 2013
421
113
I tried again just turning Flight Mode off and opened the app and it actually worked two times, prompting me with “connect to network” but now, impossible again. I can’t for the life of me understand this crap.

why does it keep changing the name of the network. I used to just call them R5 and that was the one I could search for, but I can’t and it keeps changing and I have to do the whole
Process each and every time. But then it suddenly worked two times , but now nothing again...
The first time I connected , I selected connect to smartphone
then put password in iPad and opened software , that's all. Now R5 has iPad info stored in camera , and as Koeenkooi said bluetooth should be enabled. go luck.
 
  • Like
Reactions: Viggo

Viggo

EOS R5
Dec 13, 2010
4,638
1,329
That for sure makes me think something is wrong with something at my end... it might work one or two times but the third time it’s failed to connect. It’s unstable and buggy as hell. And this worked so well with the R, a real punch in the face now that I can transfer raw as well...

I ran out of battery again so I think I just have to accept that I’m back to the cameras that didn’t have WiFi....
 
  • Sad
Reactions: YuengLinger

jprusa

EOS RP
CR Pro
Apr 29, 2013
421
113
If you haven"t already just take phone and came away from house / network interference and see if you are still having trouble , at least you can rule that out .I guess you have power cycled your phone already also.