R6 Just came (possible battery charger issue)

dwarven

EOS 90D
Dec 12, 2019
175
204
I got my R6 delivered 10 minutes before I had to leave for work:cry: I only had time to get the battery charging. But after plugging it in, I noticed a sort of whine sound coming from the charger, like coil whine on high power electronics. I'm used to that with PC components, but never with a battery charger before. Do you think this is a normal thing, or should I send it to Canon for a replacement? I'd prefer not to try out a third party charger/battery right now.
 
  • Like
Reactions: Cvcarey3

ColorBlindBat

CR Pro
Aug 30, 2018
8
2
Pretty sure someone else posted with the same problem (whining).

IIRC he / she contacted Canon and let them hear it over the phone. They sent out a replacement for free.
 
  • Like
Reactions: dwarven

Mt Spokane Photography

I post too Much on Here!!
CR Pro
Mar 25, 2011
16,364
1,370
I don't think it should be doing that. I'd call Canon and ask. Its possible that a component in it is making a sound because its not potted correctly and is vibrating. I've never taken mine apart to see what's inside.
 
  • Like
Reactions: dwarven

Viggo

EOS R5
Dec 13, 2010
4,591
1,294
My R charger occasionally had a very high pitched whine. It’s always been the same thing, I used to repair electronics, a coil that vibrates, perhaps a bit “dry” windings. I never worried about it and never had any issues.
 
  • Like
Reactions: dwarven

dwarven

EOS 90D
Dec 12, 2019
175
204
I don't think it should be doing that. I'd call Canon and ask. Its possible that a component in it is making a sound because its not potted correctly and is vibrating. I've never taken mine apart to see what's inside.
I was just about to call and suddenly it's not making the noise anymore. The camera is amazing though. It's like magic coming from an a6100.