Firmware: Canon EF 100-400mm f/4.5-5.6L IS II USM v.1.0.7

liv_img

EOS R5, 5D Mark IV
Feb 7, 2011
30
18
The update gives me ERR 70 trying to update with a 5D-IV :-( I tried with two different SD SanDisk cards formatted in camera (SDXC II Extreme Pro 64GB and SDXC I Extreme Pro 512GB).

I had to reset the camera putting out the battery to recover the camera functions.

SOLVED 7 nov: I tried again with an old SD card (SanDisk Extreme Pro SD HC I 16 GB) and the firmware update worked flawlessly.
 
Last edited:

bbasiaga

Canon Shooter
Nov 15, 2011
463
539
USA
I just got this lens off the used market.....can I even update the firmware with my 5D3?

-Brian
 

Bishop80

EOS M6 Mark II
Jan 4, 2014
51
46
The update gives me ERR 70 trying to update with a 5D-IV :-( I tried with two different SD cards.

I had to reset the camera putting out the battery to recover the camera functions.
Thankfully mine updated ok, from an M6 Mark II.
 

Bishop80

EOS M6 Mark II
Jan 4, 2014
51
46
I just got this lens off the used market.....can I even update the firmware with my 5D3?
When was the 5D Mark III released... in March 2012?
1604612913200.png
 

ehouli

EOS M50
Jan 8, 2013
42
0
I had one of the first copies of this lens and I always had issues with the IS jumping and dust behind the front lens.

I sold it and switched to a prime lens, but Canon really took long to figure out the issues.
 

bbasiaga

Canon Shooter
Nov 15, 2011
463
539
USA
So yeah, the 5D3 does have the ability to flash the firmware on lenses. You don't see it until you open the menu item for the camera firmware, and then its there. Now I know. Still probably going to follow the advice that since mine is not broken, I won't fix it.

-Brian
 

slclick

PINHOLE
Dec 17, 2013
4,586
2,947
I think the update is for using it on the R5.
Well, like the above posters, mine works flawlessly on my 5D3. However, please share your source, I have not seen any particular body mentioned in the few places who announced it such as TDP.
 
  • Like
Reactions: HeavyPiper

HeavyPiper

6D Mark II
CR Pro
Aug 1, 2018
55
34
71
I haven't seen any problems with this lens mounted on my 6D Mark II, so I to am wanting to know if this a problem with the R system bodies. Of course I'm planing on getting the R5 down the road.
 

AlanF

Stay at home
CR Pro
Aug 16, 2012
8,869
12,151
Well, like the above posters, mine works flawlessly on my 5D3. However, please share your source, I have not seen any particular body mentioned in the few places who announced it such as TDP.
As I posted earlier, my copies have had 0.0 problems on 10s and 10s of thousands of shots on a variety of bodies. There are reports on forums of IS jumping of the 400mm DO II and other lenses on the R5, which is why I suspect the upgrade is directed there.