Canon EOS R6 firmwave v1.5.0 changelog posted, download now available

koenkooi

EOS 5D Mark IV
CR Pro
Feb 25, 2015
1,948
1,915
[..]I would have preferred if the R5 had the same mode dial as the R6, which can be instantly cycled through the modes, rather than the more awkward "press centre and turn dial" method of the R5, but Canon presumably thought the posh LCD panel added a bit of class to the design.
I removed all the modes I don't use on the R5, so cycling is quite quick for me.
 
  • Like
Reactions: Fischer

tq0cr5i

EOS M6 Mark II
Jun 17, 2012
77
4
40
China
"Optimizes controls of In-Body Image Stabilization (IBIS) when using specific EF lenses not equipped with the image stabilization function."

Ah, good. I hope this applies to the EF 180mm F3.5L macro, one of my favourite lenses.
Please test this and share here.
 
Oct 14, 2021
4
9
Good morninh to ALL.
What I need in next firmware is to be able to change from Q MENU people to animals or car.It's a very significant lack.
This. I currently have it mapped under 'My Menu' as 2nd best option. And I would also very much like to have the C1, C2 and C3 modes also being available for video shooting... Otherwise pretty happy with FW 1.5.0 so far :-D
 
Last edited:

entoman

wildlife photography
May 8, 2015
568
666
UK
Please test this and share here.
I'll be in Kenya for the next couple of weeks using the 180mm macro to photograph butterflies and dragonflies, so that should provide an answer about whether the IBIS is more efficient with the non-stabilised 180mm after the firmware upgrade.
 

entoman

wildlife photography
May 8, 2015
568
666
UK
(Not sure why there's error in the R5 firmware thread where I can't comment)
Unlikely to be an error, more like a deliberate choice. After all, the update features for the R5 and R6 are identical, so it would be pointless having a separate thread devoted to each. Perhaps the best idea would have been to just combine the R5 and R6 articles so they had a common thread.
 

entoman

wildlife photography
May 8, 2015
568
666
UK
That’s interesting to know.

For me it has been the exact opposite - I had 3-4 lockups using really fast CF-express cards (happened when data was writing to the card). I now use 170MB/s SD cards and have not had 1 lockup in over 20,000 frames. These days I just keep the CF express for taking 8k clips.. but have learnt not to trust them for stills (specifically for my camera).
What CF-E cards were you using when you had the lockups, and under what circumstances did the lockups occur? (were you shooting long bursts?)

I use Delkin 128GB (Read 1730, write 1540) shooting short RAW 3 or 4 frame bursts on the R5.

I'm pretty sure that my rare lockups occurred because I was simultaneously shooting JPEGs to an old SanDisk 64GB (Read 90, write 40).

It's tempting to keep old slow cards and use them for JPEG backups, but probably a better idea to dump them and only use the fastest cards available, when using high performance cameras such as the R5.

The problem is that these fast cards are very expensive, and there's no way of telling whether they are faulty until you start using them. I once bought a pack of four SanDisk Extreme Pro 64GB SD cards, which were all faulty - in my 5DMkiv the cards half-filled, and after that all subsequent frames were blank, with yellow warning triangles replacing the images. The cards were pre-formatted in the camera. Luckily I shoot duplicates to the CF card, and they were fine.
 
Last edited:

vladk

EOS M6 Mark II
Mar 10, 2021
50
62
As usual, I will wait for couple weeks before applying this update. Hope no bugs this time.
 

sfericean

R6 x 2 & 1DXIII x 2
CR Pro
Sep 2, 2018
85
167
Bellflower, CA
www.youtube.com
I am struggling to understand the shoot to white balance feature. It seems to work correctly but then I get nothing to confirm the white balance aquired. Below are the steps that I'm taking. Am I doing something incorrectly?

1. Live view
2. "Q" button on upper right of screen.
3. White balance (3rd button down on the screen on the right)
4. Select custom white balance icon on the bottom row of the screen.
5. Select "Shoot to set WB"
6. Take a picture. To clarify; the little box does in fact show up on the screen where its attempting to take a WB reading.

And then the screen in the attached file. I've pressed the, set button, the info button, the trash button, I've attempted to move the AF selecter up and down. Nothing seems to happen at the end of that sequence and when the camera returns to live view, its certainly not the correct white balance. Its a very cool WB, nothing like the picture taken in an attempt to aquire WB.

Hopefully I'm making sense here.
 

Attachments

  • 20211203_103737.jpg
    20211203_103737.jpg
    425.9 KB · Views: 34
Last edited:

Alan B

1DX Mark III
Feb 2, 2021
44
89
As usual, I will wait for couple weeks before applying this update. Hope no bugs this time.
All latest updates for the R5, R6 and 1DXMKIII have been taken down from Canon UK(and other Canon sites). So there must be a problem ?
 

HenryL

EOS R3, R5
CR Pro
Apr 1, 2020
340
901
All latest updates for the R5, R6 and 1DXMKIII have been taken down from Canon UK(and other Canon sites). So there must be a problem ?
All three still available on Canon USA website.

EDIT: Also still available on Canon Australia's site.
 
Last edited:

rosw

EOS R
Sep 13, 2012
35
8

CanonGrunt

C70
CR Pro
Jan 28, 2012
262
169
"Optimizes controls of In-Body Image Stabilization (IBIS) when using specific EF lenses not equipped with the image stabilization function."

Ah, good. I hope this applies to the EF 180mm F3.5L macro, one of my favourite lenses.
Ditto! My most used lens on my R6 these days.
 

Berowne

... they sparkle still the right Promethean fire.
Jun 7, 2014
366
257
Not true, that version still has the IBIS bug. On the first shot after waking up the camera from power saving mode, the sensor always tilts and may blur the corners of the picture, if the shutter speed is low enough. If you're in burst mode, it may affect several shots.

Plus, you're missing new features.

Anyway, I'm keeping a backup of all previous firmwares since I bought my R6, just in case I ever need to downgrade (which hasn't been the case so far).
Ok, convinced and updated to FM vs. 1.3.1. :)
 

jeffa4444

EOS 5D Mark IV
Feb 28, 2013
1,548
198
68
UK site has definately taken down the firmware updates. I had already installed on my R6 so far no problems fingers crossed.