Canon Professional Print and Layout issues with MacOS Monterey

amorse

EOS R
Jan 26, 2017
823
1,114
www.instagram.com
I recently upgraded my photo editing computer (16" 2021 MacBook pro), and ran into some issues with the continued use of my PRO-200 using professional print and layout. The application would open without any issue and appears largely normal, but in attempting to print using an ICC profile, no profiles will load, and any attempt to print (or soft proof) crashes the program immediately. After a week or so of troubleshooting/googling/scouring support forums I decided I was out of my depth and called Canon. After some further troubleshooting and discussion they confirmed over the phone that there is a known issue with the application and Monterey.

I was unable to find any confirmation of the issue online in my effort to trouble shoot, so I thought I'd post here for any others that have been pulling their hair out trying to trouble shoot the same issue. And now we wait!
 
  • Like
Reactions: StoicalEtcher

StoicalEtcher

EOS RP
CR Pro
Jan 3, 2018
416
357
Yorkshire
Thanks for posting - we get all new Apples in about two weeks' time (M1 iMacs, M1Max 14" laptops) and I'm hoping the IT guys will ensure everything works and talks to everything else, but I'm skeptical - so postings like this help :)
 
  • Like
Reactions: amorse

privatebydesign

I post too Much on Here!!
CR Pro
Jan 29, 2011
10,631
5,980
I had an issue with Canon PP&L with an earlier version of Apple not being able to print borderless. After days talking through it with Canon who seem to have all the time in the world for their professional products, they agreed it was a Canon/Apple issue. Turned out it was an Adobe issue and a later update of PS fixed it.
 

amorse

EOS R
Jan 26, 2017
823
1,114
www.instagram.com
I had an issue with Canon PP&L with an earlier version of Apple not being able to print borderless. After days talking through it with Canon who seem to have all the time in the world for their professional products, they agreed it was a Canon/Apple issue. Turned out it was an Adobe issue and a later update of PS fixed it.
That's interesting that it fell back to Adobe. Was that printing direct from adobe using the PP&L plugin or direct from PP&L?

The rep I spoke to insinuated this was an apple problem, so I've just been using my old computer in the interim. Not ideal, but at least the prints will keep moving for now.
 

privatebydesign

I post too Much on Here!!
CR Pro
Jan 29, 2011
10,631
5,980
That's interesting that it fell back to Adobe. Was that printing direct from adobe using the PP&L plugin or direct from PP&L?

The rep I spoke to insinuated this was an apple problem, so I've just been using my old computer in the interim. Not ideal, but at least the prints will keep moving for now.
I've got to be honest and say we tried so many combinations of PS-LR-PP&L and even Preview I couldn't tell you, I spent literally days reloading firmware etc etc. I do know the only way I could print borderless with the Pro-2000 at one point was to use an older version of PS.

The weirdest bit was when you got the 'preview' in PP&L it showed the print extending to the edge and you could adjust the overlap, just like normal, but when it actually printed it printed with a 0.25" border.
 
  • Like
Reactions: amorse