R5 not showing Exposure Simulation with flash - solution found.

zonefocus

I'm New Here
CR Pro
Jul 6, 2020
12
28
Hi all just got my godox flash and trigger and quickly playing with it on the R5 I have discovered a little hack the camera setting a little hack required to overcome the issue where the exposure simulation is turned off by the trigger or flash being mounted on the camera. This is useful when mixing flash and ambient. I thought the only way to overcome this was to turn the flash or trigger off, set your exposure for ambient, then turn the flash on again. However I discovered the long pressing DOF preview button shows your actual exposure. Then dug through the manual and this sentence on page 262 all of a sudden made sense in the context of using a flash

"Normally, the image is displayed at standard brightness, so it is easy to see ( ). Only when you hold down the depth-of-field preview button will image brightness resemble actual brightness (exposure) of the resulting image ( )."

Note that this works when you have exposure set to "enable", but the DOF preview button set to something else eg aspect ratio- it requires an initial press, don't change the setting it is programmed to, but rather release and long press. This activates this exposure sim when the flash is connected. Weird. Solution found!!
 
Last edited:
  • Like
Reactions: YuengLinger

YuengLinger

Sufficiently Pixilated
CR Pro
Dec 20, 2012
3,020
1,310
USA
Super useful discovery! Could you please clarify a little? Do you mean the DOF Preview must be set to something other than original function? Or that it can also work if programmed for another function and you give it an initial press then long press? THANKS!
 

zonefocus

I'm New Here
CR Pro
Jul 6, 2020
12
28
Super useful discovery! Could you please clarify a little? Do you mean the DOF Preview must be set to something other than original function? Or that it can also work if programmed for another function and you give it an initial press then long press? THANKS!
Set the button to change aspect ratio. That’s what I had it set on when I discovered this. don’t select anything. Simply press and re-press And it should work for you. Love it if someone could confirm it works for them too.
 
  • Like
Reactions: YuengLinger

YuengLinger

Sufficiently Pixilated
CR Pro
Dec 20, 2012
3,020
1,310
USA
Set the button to change aspect ratio. That’s what I had it set on when I discovered this. don’t select anything. Simply press and re-press And it should work for you. Love it if someone could confirm it works for them too.
Thank you. Please see my comment in the other thread with this topic--and note that the R does not have a dedicated DoF button, but the instructions are the same!