F2 135mm prime tapping out in AF in dark room?

Jan 17, 2013
155
2
#1
Hey gang,

I usually shoot the R (and previously the 5D3) at a local bar with musicians, iso 800-1600, f4 shutter 160 with a F2.8 24-70 MK2. Rarely have AF lock issues. Swapped it out with a faster F2 135 for a few shots, switching to F2 for DOF. Same location and subject as my f2.8 24-72. The R was having problems locking, flaying everywhere! IT was a faster lens than my 24-70 and yet it had problems locking the same subject, same location.

Any ideas or similar experience? thanks peeps!
 

Mt Spokane Photography

Spends Too Much Time on This Forum
Mar 25, 2011
14,904
316
#2
Something is wrong, it should AF fine. I'd contact Canon and ask them if there is a issue, I've sold my 135, but all my lenses focus very quickly on my R, including some 3rd party lenses. The older consumer lenses like my 50mm macro are slower, but never hunt or had a issue locking focus. My 100-400L with 1.4 and 2X TC's stacked snaps to AF as long as the focus is in the general area already, it never hunts. Thats a really tough situation, since its f/13 or f/14.
 
Jan 17, 2013
155
2
#3
thx Mt Spokane

I had swapped lenses without turning the camera off since I didn't want to break the wifi connection to my iPad. It was DLing images while I shot. Thats the only thing I can think of.
 

Mt Spokane Photography

Spends Too Much Time on This Forum
Mar 25, 2011
14,904
316
#4
Canon, of course, tells you to power off to change a lens, thats partly because a shutter closes with power off to keep dirt from the sensor, I've changed lenses with power on, but usually turn it off. I like the switch, its easy to operate, I have little if any dexterity in my fingers.